同时装了python3和python2,怎么用pip?

ubuntu13.04, 系统内同时装了python3.3 和 2.7用sudo apt-get install python-pipsudo apt-get install python3-pip分别装了两个版本对应的pip但是现在运行pip install 只能给2.7版安装库(好像是因为重名只能调用python-pip),怎么样设置才能给3.3版安装呢?回复内容:
python3的用pip3
pip,pip2,pip3 对于linuxpy -2 -m pip install sth,py -3 -m pip install sth 对于windows
详见官方文档

https://docs.python.org/3/installing/
mac自带py2.7,自己安装了pip

转帖-[官解]windows上python2和3如何兼容

想学习python3,但是暂时又离不开python2。在windows上如何让它们共存呢?

目前国内网站经常会让大家把其中一个python.exe改个名字(嗯,我也这样讲过,在此纠正一下),这样区分开两个可执行文件的名字,但是这样做有一个重大的隐患,就是修改了名字的那个python对应的pip将无法使用。

官方的解法是什么?

事实上这个问题几年以前python社区就给出了官方解决方案,只不过国内一直没有注意到罢了。

我们在安装python3(>=3.3)时,python的安装包实际上在系统中安装了一个启动器py.exe,默认放置在文件夹c:\windows\下面。这个启动器允许我们指定使用python2还是python3来运行代码(当然前提是你已经成功安装了python2和python3)。

有关python2和3的安装,可以参见python部落(http://python.freelycode.com)–>影音学堂–>《0基础1小时,python入门》的第一节。

如果你有一个python文件叫 hello.py,那么你可以这样用python2运行它

py -2 hello.py

类似的,如果你想用python3运行它,就这样

py -3 hello.py

去掉参数 -2/-3

每次运行都要加入参数-2/-3还是比较麻烦,所以py.exe这个启动器允许你在代码中加入说明,表明这个文件应该是由python2解释运行,还是由python3解释运行。说明的方法是在代码文件的最开始加入一行

#! python2

或者

#! python3

分别表示该代码文件使用python2或者python3解释运行。这样,运行的时候你的命令就可以简化为

py hello.py

使用pip

当python2和python3同时存在于windows上时,它们对应的pip都叫pip.exe,所以不能够直接使用 pip install 命令来安装软件包。而是要使用启动器py.exe来指定pip的版本。命令如下:

py -2 -m pip install xxxx

-2 还是表示使用 python2,-m pip 表示运行 pip 模块,也就是运行pip命令了。如果是为python3安装软件,那么命令类似的变成

py -3 -m pip install xxxx

#! python2 和 # coding: utf-8 哪个写在前面?

对于python2用户还有另外一个困惑,python2要在代码文件顶部增加一行说明,才能够在代码中使用中文。如果指明使用的python版本也需要在文件顶部增加一行,那哪一行应该放在第一行呢?

#! python2 需要放在第一行,编码说明可以放在第二行。所以文件开头应该类似于:

#! python2
# coding: utf-8

提供一个windows下的解决方案:先安好的python2的pip,它的默认路径是c:\python27\scripts看到没有,它怕你找不到,自己给自己起了3个名字,随便你用哪个。然后安装python3的pip,它的默认路径是c:\users\***\appdata\local\programs\python\python35-32\scripts也是3个名字。然后你把这两个路径填加到环境变量中,就可以愉快的用pip2 install … (python2)pip3 install … (python3)分别安装库了。
为了回答这个问题,特意跑到一台 centos 6.5 上装了一个 python3(手头没有 ubuntu 的环境),然后又装了一个 pip,通过ln创建连接、alias创建别名这些操作,证明python2 和 python3 还是可以完美并存的。题主的问题不在于能不能并存,而在于用默认的 pip install 命令给python3 安装这个做法本身就是错误的,下面是我的解决方案:环境上之前已经有了 python 和 pip,

# python –version:
python 2.7.9
# pip –version
pip 8.1.1 from /usr/local/lib/python2.7/site-packages (python 2.7)

同上,用 virtualenv pip: www.pip-installer.orgvirtualenv: http://www.virtualenv.orgvirtualenvwrapper: http://virtualenvwrapper.readthedocs.org
virtualenv 是 lib 级别的隔离,如果需要python解释器的隔离,可以直接用yyuu/pyenv · github
建议用yyuu/pyenv · github , 这样可以在不修改系统自带的python的前提下,安装任意多个python版本,而且版本之间是相互隔离的,多版本管理起来很方便。
用 virtualenv 是王道。另外根据 http://packages.ubuntu.com/zh-cn/quantal/all/python3-pip/filelist 这里看,python3-pip 装出来的应该是 pip-3.2 之类。用 dpkg -l python3-pip 看一下命令全路径。

Posted in 未分类