pythonlxml模块死活安装不了怎么办?

回复内容:

static_deps=true sudo pip install lxml

试试这个?

这问题没那么神秘吧,你要先安装lxml2的c库。这是安装python实现的时候找不到它要封装的c实现在哪里。

刚从这个大坑里爬出来:

1. 安装wheel,命令行运行:

pip install wheel

首先请确认安装了xcode commond line tool 也就是xcode的命令行工具,因为编译lxml需要用到cc 等命令所以先在命令行输入

xcode-select –install

所以说,不会c语言是万万不行的。提示这么明显了,缺少头文件,那就去安装lxml的dev版本,头文件就有了
是不是装了python3?
在mac 打开终端运行命令:xcode-select –install再重试
我只想说谢谢@深海鱼
你需要安装command line tools
你是在windows下面装的吗?、

Posted in 未分类