redhatenterprise5.564位安装wxpython

感些阅读此贴。。我这个疑问困扰了好多天,如果你有思路清给些提示。 谢谢
我的系统是redhat enterprise5.5 64位 ,本身自带python2.4 不能被卸载(内和依赖严重,卸载系统会崩掉)。
我需要安装的软件需要python2.6 和 wxpython2.8的支持.
我用编译源码的方式升级到了python2.6 . 在终端 输入 “pyhon”显示如下:
[xx@localhost ~]$ python
python 2.6.8 (unknown, may 24 2012, 11:11:34)
[gcc 4.1.2 20080704 (red hat 4.1.2-52)] on linux2
type “help”, “copyright”, “credits” or “license” for more information.
证明升级成功。。

问题是 wxpython2.8 的安装我想用“rpm -ivh xxx.rpm”或 “yum install xxx” 的方式安装,不用源码方式。
发现yum是基于python2.4 的,“yum install xxx” 会把 wxpython2.8 安装到python2.4 里。
同样 rpm -ivh xxx.rpm”也会默认安装到python2.4 里。
1: 请问如何把wxpython2.8 安装到 系统的python2.6 里面。而不是python2.4里。
2:want to get advice, thank you very much.