ubuntu中安装多个版本python

ubuntu中默认就自带了python的2.5版本,结果我还是装了一个python的2.6版本,在网上查了下才知道python的2.5版本是目前使用者最多的版本,一些python的库都是用的这个版本,无奈只好再换回python的2.5版本了,其实在linux系统中多个python版本是可以共存的,只不过在终端中运行的时候,输入 python2.5 或者 python2.6就能进入不同的版本了,而且在你的*.py文件中可以用 #!/usr/bin/python 来指定程序的解释器版本,不过这样使用起来有些不方便,所以就把/usr/bin/python这个快捷方式的指向修改下好了。

: ~$ sudo rm /usr/bin/python

:~$ sudo ln -s /usr/include/python2.5 /usr/bin/python

这样在终端中输入python默认就是 2.5版本了。

很简单的,呵呵,我也是初学,这个没什么难度,就当个学习笔记吧