ubuntu8.10下安装scim

ubuntu不容易呀,终于一不小心就进入了8.10的时代了,虽然发现了不少让人不爽的bug,但是许多的新特性,还是十分值得鉴赏的。

ubuntu一个比较大的失误应该就是scim原装的拼音输入法的确不怎么的,只能按照词语输入,而且联想功能十分有限。上网搜索了一下,发现linux下面活跃的输入法还是很多的。选了一个用python加上搜狗词库的输入法来用,发现这个输入法被这么多的人赞誉也不是吹得。安装过程很简单,但是安装成功我却费了不少周折。

普通的安装我就不多说了,网上大虾写的很多了。

1,嫌麻烦的,有直接的deb包可用

2,想好好玩儿的

然后我谈谈我的安装曲折,希望对遇到这样问题的人有些帮助。

但我安装成功后,restartx,发现机器就假死在那儿了。但是我也不知道到底是什么的问题,不知道是scim还是其他的东西造成的。没办法,删掉了scim模块,重新计入x看到底发生了什么事情。top之后,可以看到一个scim一直都是僵尸进程挂在那儿。

重新安装scim模块,想看看scim设置问题,当总是发现不能启动设置程序。于是在终端启动scim-setup,发现,scim前端在和scim连接的时候,缺少了一个包libffi.so.4,而8.10默认的包,已经到了libffi.so.5了,所以scim启动的时候在这里崩溃了.可以到http://rpmfind.net/linux/rpm2html/search.php?query=libffi.so.4 下载rpm的,然后专程deb包安装。一切ok!

ubuntu包的 依赖性真是让人感觉冤冤相报何时了呀!funny!

Posted in 未分类