64位系统编译php+mysql的问题

from 包子s blog

错误信息是 /usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.so when searching for -lmysqlclient

原因

php编译用的/usr/lib/mysql这个32位的库,不兼容

解决办法

mv /usr/lib/mysql /usr/lib/mysql.orgln -s /usr/lib64/mysql /usr/lib/mysql

http://www.bkjia.com/phpjc/508452.htmlwww.bkjia.comtruehttp://www.bkjia.com/phpjc/508452.htmltecharticlefrom 包子s blog 错误信息是 /usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.so when searching for -lmysqlclient 原因 php编译用的/usr/lib/mysql这个32位…

Posted in 未分类