php多线程扩展(正儿八经的线程)pthreads安装

环境centos 6.3 64bit,php 5.4.5

pthreads需要线程安全环境,

下载php的安装包,解压:

tar zxvf php-5.4.5.tar.gz//名字是不是这个我不确定,自己去下载

安装:

./configure –enable-zts –prefix=/usr/local/php-zts

make

make install

结果就把线程安装版的php安装到了/usr/local/php-zts,目前我不了解开启线程安全到底会带来什么影响,所以,就弄两个测试版本。

下载和安装pthreads:

tar zxvf pthreads

cd pthreads-0.0.45 // 本文的是第一个stable版本

/usr/local/php-zts/bin/phpize

./configure –with-php-config=/usr/local/php-zts/bin/php-config

make

make install

/usr/local/php-zts/bin/php -i|grep “php.ini”

找出php.ini的位置,修改它把ext=pthreads.so加入进入进去,因为我原来就有php,现在新装的php.ini文件不存在我就考了一个过去……

pthreads-0.0.45/examples目录下有些示例文件,比文档有用,在线文档根本不能说明问题,我修改了一个,执行了一下:

Posted in 未分类